Why does my Outlook 2003 .Com Add-In disappears after reboot!

Status
Not open for further replies.
D

DavidA

Hi

I am trying to rollout a .Com add-in for Outlook 2003 which links Outlook to

a third party application (Gifts - www.microedge.com). The add-in installs

fine and the icon appears on the standard outlook toolbar. The link works and

does as it is supposed to.

However when the user logs off and logs back on again the icon no longer

appears, the .Com add-in does not show on the Help > About Outlook > Disabled

Items and also is not shown on Tools > Options > Other > Advanced > Com

Add-ins ..

I have tried installing the add-in as Local Admin, Domain Admin and

Administrator all with the same result. I have also added a standard user to

the local admin group and installed the add-in on their login but this also

failed on reboot.

I get no errors and no

My Setup:

Exchange Server 2007 SP1

Windows Server 2003 x64 Service Pack 2

Windows XP SP3

Outlook 2003 SP3

Any help would be great

Thanks in advance David
 
K

Ken Slovak - [MVP - Outlook]

Where is the addin registered, in HKCU or HKLM? If it's in HKLM then on

Outlook 2003 you would never see it in the COM Add-Ins dialog since it was

registered as an administrative installation. If that's the case then I'd

look into the registry and see if LoadBehavior has been changed to 2.

That can happen even without disabling the addin if you have unhandled

exceptions that aren't crashing Outlook. It can also happen if Outlook is

not exiting and on restart you are working with a hung session. I'd check in

Task Manager to verify that Outlook is actually exiting.

If it's an unhandled exception it seems to have worse effects if you are

using managed code as opposed to using unmanaged code. In addition, if you

are using managed code then you have to suspect possible load errors,

although the fact that the addin loaded once tends to discount that

possibility.

"DavidA" <DavidA> wrote in message

news:4400AEE7-0F8D-425C-AC85-FBD537A31AFD@microsoft.com...
> Hi

> I am trying to rollout a .Com add-in for Outlook 2003 which links Outlook
> to
> a third party application (Gifts - www.microedge.com). The add-in installs
> fine and the icon appears on the standard outlook toolbar. The link works
> and
> does as it is supposed to.

> However when the user logs off and logs back on again the icon no longer
> appears, the .Com add-in does not show on the Help > About Outlook

> Disabled
> Items and also is not shown on Tools > Options > Other > Advanced > Com
> Add-ins ..

> I have tried installing the add-in as Local Admin, Domain Admin and
> Administrator all with the same result. I have also added a standard user
> to
> the local admin group and installed the add-in on their login but this
> also
> failed on reboot.

> I get no errors and no

> My Setup:

> Exchange Server 2007 SP1
> Windows Server 2003 x64 Service Pack 2
> Windows XP SP3
> Outlook 2003 SP3

> Any help would be great

> Thanks in advance David
 
D

DavidA

Thanks Ken,

The Add-in is registered HKCU and I have checked the task manager and

Outlook seems to be exiting fine.

I have since found the following warning in the event viewer but I'm not

sure if this is relevant:

The COM+ Event System failed to create an instance of the subscriber

partition:{41E90F3E-56C1-4633-81C3-6E8BAC8BDD70}!new:{6295DF2D-35EE-11D1-8707-00C04FD93327}. CoGetObject returned HRESULT 8000401A.

Thanks
wrote:


> Where is the addin registered, in HKCU or HKLM? If it's in HKLM then on
> Outlook 2003 you would never see it in the COM Add-Ins dialog since it was
> registered as an administrative installation. If that's the case then I'd
> look into the registry and see if LoadBehavior has been changed to 2.

> That can happen even without disabling the addin if you have unhandled
> exceptions that aren't crashing Outlook. It can also happen if Outlook is
> not exiting and on restart you are working with a hung session. I'd check in
> Task Manager to verify that Outlook is actually exiting.

> If it's an unhandled exception it seems to have worse effects if you are
> using managed code as opposed to using unmanaged code. In addition, if you
> are using managed code then you have to suspect possible load errors,
> although the fact that the addin loaded once tends to discount that
> possibility.

> >

>

> "DavidA" <DavidA> wrote in message
> news:4400AEE7-0F8D-425C-AC85-FBD537A31AFD@microsoft.com...
> > Hi
> > I am trying to rollout a .Com add-in for Outlook 2003 which links Outlook
> > to
> > a third party application (Gifts - www.microedge.com). The add-in installs
> > fine and the icon appears on the standard outlook toolbar. The link works
> > and
> > does as it is supposed to.
> > However when the user logs off and logs back on again the icon no longer
> > appears, the .Com add-in does not show on the Help > About Outlook

> > Disabled
> > Items and also is not shown on Tools > Options > Other > Advanced > Com
> > Add-ins ..
> > I have tried installing the add-in as Local Admin, Domain Admin and
> > Administrator all with the same result. I have also added a standard user
> > to
> > the local admin group and installed the add-in on their login but this
> > also
> > failed on reboot.
> > I get no errors and no
> > My Setup:
> > Exchange Server 2007 SP1
> > Windows Server 2003 x64 Service Pack 2
> > Windows XP SP3
> > Outlook 2003 SP3
> > Any help would be great
> > Thanks in advance David


>
 
K

Ken Slovak - [MVP - Outlook]

There's really no way to tell what's going on from that information. If your

LoadBehavior is still 3 and you are registered in HKCU there shouldn't be a

reason for the addin to not at least show up in the COM Add-Ins dialog.

Do you do any error logging? I'd suggest heavily logging everything to see

if the addin is at least loading.

Are you handling all exceptions? You have to with a COM addin.

You didn't say if this was managed or unmanaged code, so I can't really

offer any other advice.

"DavidA" <DavidA> wrote in message

news:6B98756A-E89D-4020-9A88-23DE482C470B@microsoft.com...
> Thanks Ken,

> The Add-in is registered HKCU and I have checked the task manager and
> Outlook seems to be exiting fine.

> I have since found the following warning in the event viewer but I'm not
> sure if this is relevant:

> The COM+ Event System failed to create an instance of the subscriber
> partition:{41E90F3E-56C1-4633-81C3-6E8BAC8BDD70}!new:{6295DF2D-35EE-11D1-8707-00C04FD93327}.
> CoGetObject returned HRESULT 8000401A.

> Thanks
 
D

DavidA

Thanks for your help Ken, sorry I'm not that clued up with this type of

problem.

David
wrote:


> There's really no way to tell what's going on from that information. If your
> LoadBehavior is still 3 and you are registered in HKCU there shouldn't be a
> reason for the addin to not at least show up in the COM Add-Ins dialog.

> Do you do any error logging? I'd suggest heavily logging everything to see
> if the addin is at least loading.

> Are you handling all exceptions? You have to with a COM addin.

> You didn't say if this was managed or unmanaged code, so I can't really
> offer any other advice.

> >

>

> "DavidA" <DavidA> wrote in message
> news:6B98756A-E89D-4020-9A88-23DE482C470B@microsoft.com...
> > Thanks Ken,
> > The Add-in is registered HKCU and I have checked the task manager and
> > Outlook seems to be exiting fine.
> > I have since found the following warning in the event viewer but I'm not
> > sure if this is relevant:
> > The COM+ Event System failed to create an instance of the subscriber
> > partition:{41E90F3E-56C1-4633-81C3-6E8BAC8BDD70}!new:{6295DF2D-35EE-11D1-8707-00C04FD93327}.
> > CoGetObject returned HRESULT 8000401A.
> > Thanks


>
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
A File - Save Attachments does nothing in Outlook 2003 with Exchange 2010 ... Using Outlook 3
Fozzie Bear How does Outlook 2003 deals with IMAP configuration Using Outlook 8
J Does Outlook 2003 run on Windows 8 Professional? Using Outlook 2
J Outlook 2003 does not send or receive imap mail from server Using Outlook 0
E Outlook 2003 changing appointment date or time does not update on calendar Using Outlook 5
P Addressbook Outlook 2003. I am Using Vista with Office Professional Edition 2003.__I tried everthing to safe the addressbook to a CD but it does not w Using Outlook 1
M Upgrading from Excahnge 2003 to Exchange 2010 how does it effect outlook client users Exchange Server Administration 7
B Outlook 2003 does not work in window 7 Using Outlook 1
M Outlook 2003/2007/2010 not showing attachments but OWA does Using Outlook 6
J EX2010 to 2003 does not work with Outlook but does with OWA Exchange Server Administration 2
J Outlook 2010 does not show some messages after upgrade from Office 2003 to 2010 Using Outlook 1
T Outlook 2003 incoming HTML does not display correctly Using Outlook 1
N VBScript does not run in Outlook 2003 Outlook VBA and Custom Forms 4
B Outlook 2007 Custom Form does not display in 2003 Outlook VBA and Custom Forms 3
T Why does outlook 2010 convert only some forum notifications to plain text? Using Outlook 0
M Outlook .com group does not show up in Outlook for office 365 home Using Outlook 3
W Outlook Calendar does not save view any longer! Using Outlook 3
B Outlook 2016 Does not Shutdown Correctly Using Outlook 3
P Desktop doesn't index Outlook IMAP files, laptop Outlook does index those same IMAP files Using Outlook 2
J Outlook 2016 message content does not display - outlook.com; exchange Using Outlook.com accounts in Outlook 9
D Outlook 2016 IMAP Connection Returns All Email but outlook.com does NOT Using Outlook.com accounts in Outlook 2
D Outlook 2016: /altvba startup switch does not work Using Outlook 2
S Outlook does not open the .pst file created by the Outlook Using Outlook 5
O Windows 10 x64 Outlook 2013 - URL does not open (anymore) Using Outlook 3
M How does Outlook determine item numbers in a folder? Outlook VBA and Custom Forms 3
C Unchecking "Send immediately when connected" does not work on apps that call Outlook Using Outlook 1
J Outlook 2010 VBScript editor does not run code at all Outlook VBA and Custom Forms 0
G Outlook does not show new appointments in To-Do-Bar Using Outlook 0
C bcm 2010 download does not recognize outlook Using Outlook 3
A Does Outlook import Gmail Archive? Using Outlook 1
1Firefly Outlook 2013 Converstation preview does not show my last reply Exchange Server Administration 1
T outlook 2013 does not mark multiple forward messages as forward Using Outlook 2
C Outlook 2013 - Email Gets Sent - But Does Not Move From Outbox to Sent Box Using Outlook 4
M does outlook 2013/365 on mac support custom forms? Outlook VBA and Custom Forms 1
H Outlook.com calendar does not update from Outlook 2013 Home Premium Using Outlook 1
M Incoming invites to my imap account does not sync to outlook.com Using Outlook.com accounts in Outlook 29
L Outlook 2007 does not start with Apple iCloud-Add-In activated Using Outlook 2
S Outlook 2013 To Do Task does not minimize. Using Outlook 0
D Outlook 2013 deletes emails, does not send them to Deleted Items or Trash Using Outlook 2
O Outlook 2010 does not open MS Word attachments Using Outlook 1
K Outlook 2007 Calendar - Time spinner does not function correctly Using Outlook 1
M Outlook Appointment item does not show the item outside the date range Using Outlook 2
H Reocurring outlook appointment (office 2010) does not update Outlook.com Using Outlook 3
F Outlook 2010 contact e-mail Display as: does not show contact name Using Outlook 2
P Reply All does not work in Outlook 2010 Cached mode Using Outlook 4
R Outlook 2013 does not show in default programs - how do I search Using Outlook 1
U How does outlook desktop work with outlook.com Using Outlook 5
V Outlook Calendar No Reminders Show up but does on iPhone Using Outlook 0
V Outlook Calendar No Reminders Show up but does on iPhone Using Outlook 2
E Does Outlook indexing work across multiple servers? Using Outlook 0
Similar threads


















































Top