Cant rename Mailbox Database? Cant Create new Database

Status
Not open for further replies.
A

Andrew Cormier



Hi.

I have my first MBX server up. I am trying to rename the first Database to something other than Mailbox 15654599546 (or something like that). Every time I try to rename it I get Access Denied. So.. I tried creating a new Database with the desired name. Same error.

I have tried it with a non-domain admin account as well. Just put him in the Organization and Server Management group in the forest root.

I havent activated the Exchange server yet (112 days left). Could that be the problem?
 
J

jader3rd

It's not that you haven't activated the server, it would be that whatever account you're trying it with doesn't have the Proper RBAC role.
 
A

Andrew Cormier



I manually added them to the Groups above. I tried runing

Add-RoleGroupMember -domaincontroller root01 "organization management" -member "drew-da"

It says that this account is already a member. Since the group is in the forest root maybe it is a replication issue.

For renaming databases does it require Server Mgmt role, Org Mgmt role.. or both? or something else?
 
A

Andrew Cormier



Thanks Jader.

Funny thing is I dont have that role when I submit.

I can only query domain controllers in the forest root (we are in a child domain).

Here is the list of roles.

Name DisplayName
---- --------- Organization Management
Public Folder Manage...
Recipient Management
View-Only Organizati...
UM Management
Help Desk
Records Management
Discovery Management
Server Management
Delegated Setup
Hygiene Management
 
A

Andrew Cormier



Ok.. and since I only see these in the forest root, I am wondering.

When i did the prepare AD etc etc I did this from my child domain. Because of that I have read that I dont need to run the /PrepareAD switch. Could that be it? I find it odd that I have to connect to the forest root for this info.

I checked our test env and it is set up the same way.

I also tried to creat a user and dont even have access to do that so there is something that I did wrong somewhere.

Still reading.
 
A

Andrew Cormier



Ok.. I will finish this off.

I .. me .. moi... am explicitly blocked from having access to users mailboxes. This is odd. I dont know why. Worry about that later.

Created a new group in my domain. In ESM2003 delegated full exchange admin rights to that group. Put that group in the Org Mgmt group.

Created an admin account and made him admin of the servers and put him in the new admin group. It seems to work so far.

Sometimes I would do something like try to add a new database and get access denied. Wait 5 min and POOF it is there (not wait 5 minutes and try again.. it worked the first time even though it says it didnt.)

So I guess this means we are going closer to using MS's PITA best practices.

Drew
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
A Cant See outbox items on a secondary Account Exchange Server Administration 3
W Cant connect to outlook.com from outlook Using Outlook.com accounts in Outlook 2
K cant read email or open attachement Using Outlook 0
jChambler Cant install BCM on windows 10 BCM (Business Contact Manager) 12
R Cant reinstall POP email account Using Outlook 2
E Cant open open outlook2013 Using Outlook 4
Wotme Cant delete a task in task folder Using Outlook 2
V Outlook 2013 cant stay connected to exchange 2010 Exchange Server Administration 5
P cant open tasks in outlook 2010 Using Outlook 0
C Cant find emails after moving pst Using Outlook 1
L "sometimes" cant send mail, we have to copy and paste the message and resend? Using Outlook 2
M Outlook 2007 cant send email with vista Home Premium Using Outlook 8
C Outlook 2007 cant create new account Using Outlook 7
D cant open vcf file Using Outlook 1
B cant accept iCal calendar invites in Outlook 2007 (SP3) Using Outlook 4
S my account cant receive email... Using Outlook 1
P PST reached maximum size- cant delete emails to slim it down Using Outlook 5
S Why Cant i send lots of emails from my hotmail in bulk? Using Outlook 1
C Cant see detailed progress of sending and receiving Using Outlook 1
W Cant download from office PKC Using Outlook 1
H Cant open Outlook Using Outlook 2
T cant send email Using Outlook 5
M Outlook 2007 (cached mode), Exchange 2010 - Cant download Offline Address Book Exchange Server Administration 6
G Cant Open My E-Mail Using Outlook 1
N cant receive emails from internet Exchange Server Administration 5
C cant receive emails Using Outlook 7
G cant send emails using my live.com account i can receive but not send Using Outlook 2
T I cant find outlook business contact manager Using Outlook 6
B Office 2010 cant set up contacts. Using Outlook 1
A Cant open email with macro in attachment Using Outlook 1
V Password cant cahange Exchange Server Administration 1
V Password cant cahange Exchange Server Administration 5
S Outook 2002 SP3 - cant import a contact list Using Outlook 1
J cant open links sent in e-mails Using Outlook 3
A cant send a message when i attach a word doc__ message oa8f2vfv031886 Using Outlook 1
D Error Message. files cant be emailed because theres no email program on computer Using Outlook 4
K Cant view folders set up on old version of outlook - and cant access mail sent to those folders . Using Outlook 1
L Keeping Outlook contact, documents and favourites from trial programs installed. cant access these files to export them. Using Outlook 2
B Large file started sending from outlook 2003 now cant delete it Using Outlook 4
S plz Help: i cant disable password complexity in Windows Server 2008 R2 Exchange Server Administration 5
N cant send email to outsite Exchange Server Administration 2
M Cant get Exchange 2010 Update Roll up 4 to install. Error: the upgrade patch cannot be installed by Exchange Server Administration 8
R Cant send or recieve email's outside of my lan. Exchange Server Administration 7
J Outlook 2003 cant run under exchange 2010 Exchange Server Administration 3
B Cant receive/ send Emails Using Outlook 1
L new laptop(windows 7) and cant send or recieve email, Using Outlook 1
S Cant Recall message Exchange Server Administration 6
D Exchange 2010 and SBS 2003 Cant communicate Exchange Server Administration 1
A why cant my Email sent? it receives mail but no sending Using Outlook 1
T MS Word set for editor, cant find word, not installed, or wrong version for Outlook version error. Using Outlook 2
Similar threads


















































Top