OWA not working "out of the box" with Ex2010 (or after SP1, or after SP1 RU1)!

Status
Not open for further replies.
E

Ebor Computing

Hi everyone,

(This is a copy+paste+edit from another thread because I posted in an answered one - whoops!)

I have almost finished a migration from Exchange 2003 to 2010, on two different servers co-existing (reasonably) happily at the moment. I too have this " dreaded" red box / missing image thing happening with OWA. I have migrated ~30 users who are happy with just IMAPS or Outlook, but the remaining users cannot be migrated if their OWA doesn't work.

I have ran UpdateCas.ps1 in the Exchange Power Shell and it appeared to complete successfully, but restarting IIS v7.5 with " iisreset" yielded no change. Still red boxes and poor layout and links not working.

I have re-installed UR1 after letting " Windows Updates" do it for me, and that too appeared to finish fine.

I appear to have Exchange v14.1.255.0 on the file system (and in missing URLs on webpages when viewing source), but checking the Exchange Management Console shows v14.1.218.13 - almost like some things didn't quite update correctly?

Under E:\ExchangeServer\ClientAccess\Owa I have:
v14.0.639.21 v14.1.218.13, and v14.1.255.0

Out-of-the-box authentication didn't work (just sat at a redirect page with zero bytes returned to browser), so changing authentication resulted in a small box pop up for user/pass. I can now login, but just get the page with poor layout, red boxes, and no links working.

Sounds remarkably similar to posts already here, but solutions provided there didn't work, so I would love some specific help.

When set to Forms based authentication (username only) and selecting the domain, visiting https://mail.ebor.local/owa results in a redirect to https://mail.ebor.local/owa/auth/logon.aspx?url=https://mail.ebor.local/owa/&reason=0 (obviously an internal URL). No page content.

When set to domain\username, I get the same.

When set to Plain text only, I get a repeated prompt for credentials (ad infinitum?)

When set to plain text + Integrated, I get ... also the repeated prompt. Hang on, one of these setups resulted in gaining access but resulting in a broken page.

Yes, the ECP virtual directory is changed to match the OWA virtual directory authentication settings, and an 'iisreset' is performed after each configuration change.

Thanks in advance,

-- Ebor Administrator
 
E

Ebor Computing

As an update to this " not working" thread, I'll update it with a few of the things I've tried in an attempt to stimulate some conversation.

I've used the EMC to reset the directories (again) - the OWA, ECP and EWS virtual directories. For some reason the External Site Name was lost in this process, so I set the authentication mode and the external site names and reset IIS, using:
Set-OwaVirtualDirectory -LogonFormat 'UserName' -DefaultDomain 'xxxxxx.local' -Identity 'MAIL1\owa (Default Web Site)' -ExternalUrl 'https://xxx.xxx.com/owa' Set-EcpVirtualDirectory -ExternalUrl 'https://xxx.xxx.com/ecp' -FormsAuthentication $true iisreset

This code was taken from the GUI's " Show Exchange Management Shell command" window.

Visiting the Internal OWA page, I was then able to see an actual logon page. Wow. Why does doing the same thing again on a different day, yield different results!?

Now, testing login didn't work. I end up with a page saying:
Outlook Web App didn't initialize. If the problem continues, please contact your helpdesk.
Show details
Request
Url: https://xxx.ebor.local:443/owa/auth/error.aspx
User host address: 192.168.xx.xxx
OWA version: 14.1.255.0

Nice and helpful. It would be nice to have something to say why it didn't initialise.

So, off I go to check Event Viewer.

I find this:

Log Name: Application Source: MSExchange OWA Date: 26/11/2010 10:36:34 AM Event ID: 29 Task Category: Configuration Level: Error Keywords: Classic User: N/A Computer: xxx.ebor.local Description: There's an error in your configuration. The authentication type specified in the E:\ExchangeServer\ClientAccess\owa\web.config file is incorrect. The correct authentication type is " Windows" . Event Xml: <Event xmlns=" http://schemas.microsoft.com/win/2004/08/events/event" > <System> <Provider Name=" MSExchange OWA" /> <EventID Qualifiers=" 49152" >29</EventID> <Level>2</Level> <Task>3</Task> <Keywords>0x80000000000000</Keywords> <TimeCreated SystemTime=" 2010-11-26T00:06:34.000000000Z" /> <EventRecordID>41382</EventRecordID> <Channel>Application</Channel> <Computer>xxx.ebor.local</Computer> <Security /> </System> <EventData> <Data>E:\ExchangeServer\ClientAccess\owa\</Data> </EventData> </Event>

If the correct (and only ??) authentication type is " Windows" then why does it give you an option to set it to something else? Should it be changed in the web.config using Notepad, or should it be changed using PowerShell?

I'll try with just changing the authentication type using Notepad. I'm sure the associated parameters would then be wrong, but I'll try.

Running iisreset and hitting refresh on the web page error message.... (I can't believe this) actually worked !!!!

Untested with a real user, or externally yet, so I'm hesitant to say it's all working. Will follow up with further testing.

-- Ebor Administrator
 
E

Ebor Computing

More users tested (internally) and it appears to be working. when checking out the " options" for the users, they all receive a new login page, and when attempting to login they receive:

The user name or password you entered isn't correct. Try entering it again.

I think it's fibbing.

Checking with https://<server>/ecp I get the same response.

/owa works though.

Making the same change to the ECP web.config file and resetting IIS enabled Options for users.

-- Ebor Administrator
 
E

Ebor Computing

Every now and then, visiting the old mail server OWA URL externally redirects to the new mail server internally . (ie: it has a dot local hostname) Not a great help when you're external. Sometimes waiting and revisiting the page works. Sometimes you just have to visit the new mail server external address directly. <shrugs> Dunno why.

Apart from that, this setup appears to be (mostly) working.

Can't wait for the next update to break things!

-- Ebor Administrator
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
G OWA premium not working for new mailboxes - Corrupt restriction filter data Using Outlook 4
S OWA in Exchange 20120 not working after installing a new certificate and applying SP1 Exchange Server Administration 1
A Exchange 2007 <-> 2010 OWA not working together redirecting problem Exchange Server Administration 1
J OWA not working when active database moved Exchange Server Administration 3
S Exchange 2010 owa https not working Exchange Server Administration 5
B Exchange 2010 OWA not working on client- Ex2k7 worked Using Outlook 4
B Exchange 2010 Migration - OWA not working Exchange Server Administration 2
K Exchange 2003 SP2 OWA error 500 / unspecified on Frontend, while OMA and ActiveSync is working, even Using Outlook 3
H OWA not working because of TMG Certificate Using Outlook 4
A OWA 2007 spell check stopped working for our language Using Outlook 2
E OWA 2010 Stop Working Randomly Exchange Server Administration 2
I Public Folders not working in OWA Exchange Server Administration 2
H Exchange 2010 SP1: HTTP redirect not working and OWA issues Exchange Server Administration 5
C OWA via UAG not working Exchange Server Administration 4
P OWA Settings->Calendar->Events from Email; Setting changes do not hold Using Outlook 1
G How to have domain client use owa server instead of exchange server while connect to network Using Outlook 1
J OWA vs. Outlook 2016 Bandwidth Exchange Server Administration 1
O Synchronize safe persons Outlook 2016 -> Outlook Web Access (OWA) Using Outlook 30
C OWA External Access - No URL / URL Invalid Exchange Server Administration 2
Diane Poremsky New Office365 Feature: URL Preview in OWA New Slipstick.com Articles 0
J IPAD Outlook OWA App - Help using Exchange 2007 Using Outlook 4
S Cannot disable OWA light Exchange Server Administration 5
J Stuck using OWA Exchange Server Administration 0
T Outlook Calendar Sync MY GOAL: see work calendar on home desktop w/o OWA Using Outlook 2
T Sync OWA? Exchange Server Administration 0
O Multiple simulteniously opened OWA 2010 accounts in one browser work fine ! Using Outlook 3
S Newly added user doesn't show up in GAL but available in OWA, Using Outlook 0
B Customize OWA page to open in a new window when logging in Exchange Server Administration 1
B OWA Calendar Views not available Exchange Server Administration 2
O outlook 2010, owa, exchange Exchange Server Administration 2
B Searching OWA Additional Mailbox - in which Secondary folder is the email? Using Outlook 1
D OWA and Windows 8 Exchange Server Administration 1
Z OWA Mailbox unavailable Exchange Server Administration 2
G Outlook 2013: Getting meeting invites in OWA format Using Outlook 9
R Lost Outlook 2007 message found in OWA Using Outlook 4
D OWA Send invitation AS (not from) Exchange Server Administration 1
E OWA phones home too much? Exchange Server Administration 1
S Cannot open any attachment from OWA Exchange Server Administration 2
T Syncing OWA 2010 to Outlook 2007 Exchange Server Administration 15
R OWA can't delete mail Exchange Server Administration 8
J Outlook and owa access Using Outlook 1
S Track emails in OWA Exchange Server Administration 1
T OWA and post dating Exchange Server Administration 1
S Unable to Sync Phones but OWA connects Exchange Server Administration 1
B [SOLVED] Forced to type Domain/username for OWA 2003 with IE 7 or 8 Exchange Server Administration 3
M Attachments cannot be opened in Outlook, OWA works fine Using Outlook 2
T OWA Folders Using Outlook 0
A Managing GAL via OWA Exchange Server Administration 5
J Mail read in OWA won't appear in Outlook Exchange Server Administration 1
1 mobile OS or apps for sync of all OWA/exchange PIM functions Exchange Server Administration 3
Similar threads


















































Top