ex2010 edge transport - inbound from internet

Status
Not open for further replies.
J

JayCrumpGP

Hi, I have recently stood up a pair of edge transport boxes (one in each AD site that hosts ex2010) and have mail flow outbound just fine. I just swapped the MX record out on one of our domains (we accept for around 40 domains) so that the edge would start capturing inbound mail to this domain. MX record looks good on the internet, firewall in front of edge looks fine for accepting inbound tcp25 to the edge, the edge itself will answer on tcp25, but mail to the domain is never passed on to the internal HT server. I can telnet to tcp25 of the HT from the edge just fine as well.

Am I overlooking something in config here? I've made no changes to the two send connectors at all - and I have another organization that this works fine for on ex2007 (much simpler config, only one domain accepted for inbound email). Thanks in advance.
 
L

Leif Pedersen [MVP]

Hi,

Are the inbound mails queued on the edge server or rejected?

If queued any error message in the queue viewer?

Leif
 
E

Ed Crowley [MVP]

Before switching the MX record, you should have run a telnet to port 25 of each Edge server to send a message to a mailbox to ensure that inbound mailflow works.Ed Crowley MVP " There are seldom good technological solutions to behavioral problems."
 
J

JayCrumpGP

Hindsight! :) - thanks.

I've only cut MX for one (and it's a brand new domain), so I'm ok in that respect. Will open a ticket to see what's up.

Thanks for the replies.
 
G

Gavin-Zhang

Hi JayCrumpGP,

Per my known, Accepted domains are configured as global settings for the Exchange organization and on computers that have the Edge Transport server role installed. You must configure every domain for which your Hub Transport servers relay or deliver messages as an accepted domain in your organization. The Edge Transport server requires that all domains for which it accepts and relays messages are configured as accepted domains.

We recommend that you create and manage all accepted domains inside the organization and synchronize that information to the Edge Transport server by creating an Edge Subscription.
Some information for you:
http://technet.microsoft.com/en-us/library/bb124423.aspx
Regards!
Gavin
 
J

JayCrumpGP

Hi,

the edge subscription has been in place for a while and is working (all accepted domains internally do show up on the edge) - I've just only been using the edge servers for outbound flow. This domain is the first that I've turned on inbound flow for (by changing the MX record - all the rest of my domains still point at another type of inbound MTA).

I can telnet to the edge server from another machine outside of my organization on port 25 just fine. I can even send a message over telnet. It just won't accept a true message from any other system.
 
G

Gavin-Zhang

Hi Jay,
If you have configure your accecpt domains on the internal and your edge server, I would suggest that you could run the mailflow analyzer check your mailflow. check your connector on the edge server and the hub server configured correctly.
ss or the FQDN of the MX record.
Did external sender accept some NDR, what is it?
I would also check the log on the edge server for the failed email, and confirm the issue.
Regards!
Gavin
 
J

JayCrumpGP

Thanks for the responses. Problem solved! We typically host our own DNS for all domains, but for this particular one, another company holds authority over the namespace.

They mucked up the MX records for this domain......after correcting, all is working as expected. I shouldn't be under the assumption that other people do their work correctly I guess....

At any rate, thanks for the responses. going to mark this one closed.
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
G Ex2010: Edge Sync / SynStatus Inconclusive? Exchange Server Administration 7
C Ex2010 problems with mail-enabled public folders Exchange Server Administration 0
M How do I get a copy of the NDRs sent to an administrator in EX2010 Exchange Server Administration 4
N EX2010 SP1 RU2 - High CPU Usage - Exchange Search Servuce Exchange Server Administration 4
M Recommended Reboots for EX2010 Exchange Server Administration 6
R cannot uninstall EX2003 after transition to EX2010 Exchange Server Administration 6
L Following migration from EX2k3 to Ex2010 meeting requests do not appear as tentative Exchange Server Administration 2
A EX2010 ERROR Exchange Server Administration 4
M EX2007 - EX2010 - Public Folder Migration, some items are missing with MSExchange Store Driver 1020 Exchange Server Administration 1
P Ex2010 active sync Exchange Server Administration 4
R Transition from Ex2003 to Ex2010 Exchange Server Administration 11
P Migrating Exchange 2007 to 2010 no mail going between servers or out from the Ex2010 servrer Exchange Server Administration 6
C ex2010 outlook03 autodiscover working??? Using Outlook 5
E OWA not working "out of the box" with Ex2010 (or after SP1, or after SP1 RU1)! Exchange Server Administration 3
P Migration Ex2003 to Ex2010 problem, cannot see old mailboxes/users Exchange Server Administration 32
J EX2010 to 2003 does not work with Outlook but does with OWA Exchange Server Administration 2
Y Public Folders move from EX2007 to EX2010 Exchange Server Administration 2
R Ex2003 to Ex2010 Migration - how to remove orphaned public folder replicas on Ex2003? Exchange Server Administration 19
A Does I need to move & upgrade Default Address Lists from EX2003 to EX2010 Server Exchange Server Administration 12
A not able to change password by EX2010 OWA for few user's Exchange Server Administration 26
M outlook client gives security alert after setting up EX2010 owa on server Exchange Server Administration 7
M Mailbox Database failover in Ex2010 RC Exchange Server Administration 7
M Looking for options and best practices for an Edge Server (Exchange or not) Exchange Server Administration 0
J Edge + TMG 2010 No email inbound/outbound and cannot telnet to port 25 on TMG Exchange Server Administration 0
J CPA cuts off left edge of printed Calendar. Ex. January the J is cut off. Calendar Printing Assistant 11
A Exchange 2010 SP1 Edge Server ( Content Filtering ) Exchange Server Administration 0
S Configure Exchange Edge 2010 on TMG in DMZ Exchange Server Administration 1
S Edge Transport 3rd party mail filter before Exchange 2010 Exchange Server Administration 5
M join internet domain without edge server to the internal DC domain Exchange Server Administration 4
S Exchange 2003 coexistence with Exchange 2010 (Edge, OWA, Certificate, DNS considerations) Exchange Server Administration 3
S Edge 2010 and Forefront 2010 in DMZ Exchange Server Administration 12
S Edge 2010 and TMG on the same box Exchange Server Administration 1
S Forefront TMG Management Control 2010 on Edge Server. Exchange Server Administration 1
S how to print all emails sent and received via edge in 2010 Exchange Server Administration 13
M Re: How to force routing between two internal smtp domains across Two Edge servers Exchange Server Administration 7
M How to force routing between two internal smtp domains across Two Edge servers Exchange Server Administration 3
K Edge to Hub to Exchange 2003 Exchange Server Administration 4
K Edge SyncStatus: Inconclusive Exchange Server Administration 2
T Prerequisites softwares for installing exchange 2010 edge transport server on windows 2008 R2 Exchange Server Administration 1
N Exchnage 2010 Hub Cas Edge Server Recovery Exchange Server Administration 3
K Edge Hub testing Exchange Server Administration 10
K Edge transport and TMG best practice NLB Exchange Server Administration 1
R Exchange 2010 Edge Transport server not passing emails... Exchange Server Administration 7
A Hub 2010 to Edge 2007 ( Last Error: 421 4.4.2 Connection dropped due to ConnectionReset ) Exchange Server Administration 3
P Exchange 2010 Edge Transport Delays mail Exchange Server Administration 5
H Setting up an Edge Transport Server - Exch 2010 Exchange Server Administration 11
D exchange 2010 edge smtp authentication Exchange Server Administration 7
Z Hub Transport and Edge is not working as it should Exchange Server Administration 12
L Plethora of Event ID FAILs on the Edge Transport Exchange Server Administration 4
L Exchange server 2010 edge to hub-transport routing error Exchange Server Administration 9
Similar threads


















































Top