Since Exchange 2010 SP1 upgrade, Mail Submission service is restarting every 24 hours in the early m

Status
Not open for further replies.
L

LemonJoy

Saw some other reports of this on msexchangeteam's site - is there a resolution? We upgraded this past weekend & are seeing this event item regularly.

Alert: The Microsoft Exchange Mail Submission service (MSExchangeMailSubmission) isn't running.

Source: Services - xxxxxx(Mailbox) - ADsite

Path: xxxxxx.com;xxxx(Mailbox) - ADsite Last modified by: System Last modified time: 10/28/2010 1:33:37 AM Alert description: Submits messages from the Mailbox server to the Hub Transport servers.

State: 1

ServiceType: 16

StartMode: 2

ErrorControl: 1

TagId: 0

ProcessId: 0

Name: MSExchangeMailSubmission

BinaryPathName: " C:\Program Files\Microsoft\Exchange Server\V14\Bin\MSExchangeMailSubmission.exe"

Dependencies: MSExchangeADTopology

ServiceStartName: LocalSystem

DisplayName: Microsoft Exchange Mail Submission

Joy
 
K

Khoj Sahiwala

Please check for any events which are taking place prior to the start.

Background cleanup , especially AV and what it is scanning.
http://technet.microsoft.com/en-us/library/bb332342.aspx

Arew there any other events especially in the system event viewer for the reason for this service.

please increase disgnmostics logging of the submission service.
 
L

LemonJoy

no AV on the mail servers, but will certainly look at any background cleanup entries prior to this entry. Thx.Joy
 
L

LemonJoy

some mailbox assistant tasks going on prior, and a couple " windows error reporting" items after the mail submission error:

Log Name: Application
Source: Windows Error Reporting
Date: 10/28/2010 1:32:51 AM
Event ID: 1001
Task Category: None
Level: Information
Keywords: Classic
User: N/A
Computer: MBX1.baupost.com
Description:
Fault bucket , type 0
Event Name: E12
Response: Not available
Cab Id: 0

Problem signature:
P1: c-RTL-AMD64
P2: 14.01.0255.000
P3: MSExchangeMailSubmission
P4: M.Exchange.StoreProvider
P5: M.M.MapiEventManager.SaveWatermarks
P6: M.Mapi.MapiExceptionArgument
P7: 69c9
P8: 14.01.0218.011
P9:
P10:

Attached files:
C:\Windows\Temp\5a0c513a-433d-42c0-b078-2e71aaddbd15\report.txt
C:\Windows\Temp\5a0c513a-433d-42c0-b078-2e71aaddbd15\report.xml

These files may be available here:
Analysis symbol:
Rechecking for solution: 0
Report Id: cc6b1c40-e254-11df-aa60-001b2128d36e
Report Status: 0
Event Xml:
<Event xmlns=" http://schemas.microsoft.com/win/2004/08/events/event" >
<System>
<Provider Name=" Windows Error Reporting" />
<EventID Qualifiers=" 0" >1001</EventID>
<Level>4</Level>
<Task>0</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime=" 2010-10-28T05:32:51.000000000Z" />
<EventRecordID>299784</EventRecordID>
<Channel>Application</Channel>
<Computer>MBX1.baupost.com</Computer>
<Security />
</System>
<EventData>
<Data>
</Data>
<Data>0</Data>
<Data>E12</Data>
<Data>Not available</Data>
<Data>0</Data>
<Data>c-RTL-AMD64</Data>
<Data>14.01.0255.000</Data>
<Data>MSExchangeMailSubmission</Data>
<Data>M.Exchange.StoreProvider</Data>
<Data>M.M.MapiEventManager.SaveWatermarks</Data>
<Data>M.Mapi.MapiExceptionArgument</Data>
<Data>69c9</Data>
<Data>14.01.0218.011</Data>
<Data>
</Data>
<Data>
</Data>
<Data>
C:\Windows\Temp\5a0c513a-433d-42c0-b078-2e71aaddbd15\report.txt
C:\Windows\Temp\5a0c513a-433d-42c0-b078-2e71aaddbd15\report.xml</Data>
<Data>
</Data>
<Data>
</Data>
<Data>0</Data>
<Data>cc6b1c40-e254-11df-aa60-001b2128d36e</Data>
<Data>0</Data>
</EventData>
</Event>

I will examine this further.

Joy
 
L

LemonJoy

Thanks, Khoj - that's where I first spotted others reporting this issue & a recommendation to post here. Will be at Exchange Connections next wk so hope to ask the experts :)Joy
 
N

NYROADIE

Microsft Tech advises that this can be caused by having empty databases and recommends having at least 1 active mailbox on each database as a work around until a fix is released. I have moved mailboxes and will see if this fixes the mailsubmission service crash.

Symptom

------------
MSExchangeMailSubmission will crash once a days

Cause

--------
A maintenance thread kicks in every 24 hours to update watermarks of idle mailboxes (worst case scenario is one crash per day). If a server has a database with zero user mailboxes or a database where all user mailboxes are 'inactive' (did not process any event, e.g. none of the users sent email) then the call to SaveWatermarks() fails. As a result, it may cause msexchangemailsubmission service crashes

Bug Status

-------------
In process

Action Plan

-------------
1. Create some mailboxes on the &ldquo;blank&rdquo; database

2. If problem still persists, please activate at least one mailbox each day, such as sending a message
UPDATE: 11-05-10 service has not crashed since applying this work around. I will contiune to monitor
 
L

LemonJoy

Thx for opening the case - we'll place some mailboxes in our blank DBs, then.Joy
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
M Exchange 2010 does not updat GAL since few days Exchange Server Administration 28
F outlook.com Exchane Server corrupts data Since September 2019 Using Outlook.com accounts in Outlook 6
E Accessing shared outlook folder doesn't work since switch to new outlook/excel Outlook VBA and Custom Forms 11
CWM030 Its been years since i've used outlook and now were up to 2016! Using Outlook 3
B Headache with Hotmail and Outlook since migration Exchange Server Administration 10
M search takes a loooong time since updating Using Outlook 8
M ctrl-c/v/x suddenly not working since installing office 2013/365 Using Outlook 1
J ever since I started using Outlook, I cannot get an email from an app I use Using Outlook 2
A Alerts on incoming emails which are not responded since 1 day Using Outlook 1
B Trouble Locating Tools Menu since There's No Standard Toolbar in Office 2010 Using Outlook 1
T I'm unable to follow links from mail since 2010 upgrade any help appreciated__ Using Outlook 1
D Outlook 2007 Slow Since Office 2010 Installed Using Outlook 1
M My outlook 2007 will not send or receive since last weeks updates. Using Outlook 3
J Outlook changing from inbox/trash/sent, etc. is EXTREMELY slow since updating Windows a couple of days ago. Is there an issue with Outlook as to the Using Outlook 2
M since setting up office outlook2007 all messages are being sent to deleted folder in webmail Using Outlook 1
I Long delay in switching folders since I installed IE 9 Beta Using Outlook 2
W Unable to sync Outlook contacts and calendar since upgrading from Outlook 2007 to Outlook 2010 Using Outlook 1
S 6 to 8 second delay in folders opening since installing a number of updates yesterday. Using Outlook 1
M Outlook email not working since last automatic update. Using Outlook 2
T space line on printing email with OWA 2010 (since SP1) Exchange Server Administration 3
M Workgroup Calendar in Groove will not display since upgrade to Office 2010 Using Outlook 1
C Since I installed Norton 360 I can not open links people send on my email Using Outlook 3
C Can not start Outlook 2007. Since viewing my POP account (yahoo mail) Using Outlook 2
B Need help with contact recovery, since trial of Office 2010 has ended. Using Outlook 2
S Since outlook connector update unable to send mail Version 14.0.5117.5000 Errors: 4102&amp; parsing MTOM Using Outlook 2
S Autocomplete has not worked since I got my new computer a month or so ago. How do I fix it so the emails are stored for autocomplete? Using Outlook 1
E Gmail IMAP not working since installing junk mail filter update Using Outlook 1
M Not receiving an error code, JUST not receiving mail since I had a temp contact spam from Windows live. I had changed my password and I'm not getting Using Outlook 1
B Problems since 10/15 downloads with MSOutlook and Yahoo. What gives? Using Outlook 1
T Outlook has stop send/receiving emails since kb2207566 installed Using Outlook 1
N Email issues since installing BCM with Outlook 2007 BCM (Business Contact Manager) 1
T Custom form created in 2003 won't print since upgrade to 2007 Outlook VBA and Custom Forms 1
T Custom form created in 2003 won't print since upgrade to 2007 Outlook VBA and Custom Forms 13
N Backing Up Exchange Calendar Using Outlook 13
A Ol16 desktopT suddenly can't connect with Exchange Using Outlook.com accounts in Outlook 5
T How can Exchange be configured to sync/push one-way so that the server data can't be affected Exchange Server Administration 0
E How to display "Change Folder" in Change Default Email Delivery Location in Exchange Outlook 2016 Using Outlook 1
J Outlook 2016 Moving IMAP emails to Exchange Using Outlook 1
L How to Import Exchange OST file into Outlook? Using Outlook 3
O Outlook 365 Exchange .ost within Personal Vaul Using Outlook 0
D Outlook 2016 Migrate 'On My Computer' (local storage) Calendar from Mac Outlook to Exchange Account Using Outlook 5
A .restrict results changing after moving to Exchange online Outlook VBA and Custom Forms 0
D Can Exchange Admin Center create a pst for users email/contacts/calendar? Exchange Server Administration 0
S Messages moved / deleted by auto-archive are not synchronized to exchange Exchange Server Administration 8
llama_thumper Setting up forwarders on Exchange server Exchange Server Administration 0
D Importing Outlook Categories from another domain (Exchange 2016/Outlook 2016) Using Outlook 4
M WMI query for Get Disk IO performance in exchange Exchange Server Administration 0
B Outlook 2013/Exchange 2013 - Conf Rooms not fully booking "resolved conflict" meetings Using Outlook 3
D Adding Enterprise Exchange Email Account to Outlook Prevents Sending via Outlook.com Account Using Outlook.com accounts in Outlook 10
O Benefits of Exchange over IMAP and why would I choose Exchange? Using Outlook 2
Similar threads


















































Top