Priority Queuing

Status
Not open for further replies.
J

J-H

Hi

I would like to learn and test priority queuing - http://technet.microsoft.com/en-us/library/bb691107.aspx

I increased the diagnostic logging of MSExchange Transport components but I do not see any priority related events in the application log. How can I investigate what happens related to priority queuing on the transport server?

The above TechNet article contains this section:

#

The Set-Mailbox cmdlet in the Exchange Management Shell has the DowngradeHighPriorityMessagesEnabled parameter. The default value is False. When this parameter is set to True, any High priority messages sent from the mailbox are automatically downgraded to Normal priority. For more information, see Set-Mailbox.

#

However, Set-Mailbox states:

#

The DowngradeHighPriorityMessagesEnabled parameter specifies whether to prevent the mailbox from sending high priority messages to an X.400 mail system. If this parameter is set to $true and the mailbox sends a high priority message destined to an X.400 mail system, the message priority is changed to normal priority.

#

I am now wondering if priority queuing is only working with mails send to an X.400 mail system.

Regards

J-H
 
J

James-Luo

Per my research, there"s no log that recorded the details about priority queueing

If you want to test the effect of this feature, you can suspend the submission queue, send a bunch of messages with different priorities, and then resume the queue and monitor the timestamp in the message tracking log

James Luo

 
J

J-H

I did the test in a test environment with a single server using Exchange Server 2010 SP1.

[PS] C:\Program Files\Microsoft\Exchange Server\V14\Bin>findstr " PriorityQueuingEnabled" .\EdgeTransport.exe.config
<add key=" PriorityQueuingEnabled" value=" true" />

The server was restarted after the above change.

I run Get-Queue | Suspend-Queue.

I used a test mailbox with DowngradeHighPriorityMessagesEnabled : False to send 7 emails. The subject was 0..6. Mail number 4 was set to high importance and mail number 5 was set to low importance. For the other emails I did not change the importance option.

I resumed the mail queue and checked the sequence of the emails in the inbox of the recipient. They arrived in exactly the same sequence the emails have been sent.

I verified that the X-Priority header was included in the received emails - X-Priority: 1 for the high important email and X-Priority: 5 for the mail marked as low important.

I use the tracking log explorer to check the timestamp of the emails. According to my understanding the mails have been processed in sequence regardless of the X-Priority header.

Can you please give me a tip where my configuration is incorrect?

Do you have an update related to my question why Set-Mailbox states that this parameter is for emails sent to an X.400 mail system?

Should priority queuing be working for Exchange Server 2010 internal mail delivery?
 
J

James-Luo

So, messages haven"t been affected by the priority queueing feature. I have got the same result in lab (Exchange 2010 RTM). I"ll research further on it

About DowngradeHighPriorityMessagesEnabled, I will try to confirm with relevant team, and post at here when I got the update

James Luo

 
K

Kevin Ca

Hello,

I've consulted with our transport here. After some testing, this is the feedback i received:

" Priority queuing does work on internal mail delivery in Exchange 2010. The problem is that it is very hard to show in a lab environment how priority queuing works internal mail delivery. A better way to show that priority queuing works is to send messages to an external domain. When testing priority queuing it is better to use message size in conjunction with setting the message priority on message. In my lab I setup Windows 2008 that had the IIS SMTP configured to accept mail for external domain. I then created a send connector that forwards the mail for the external domain to IP address of my Windows 2008 IIS SMTP box. On my Exchange 2010 hub server I added the following entries

<add key= &ldquo;PriorityQueuingEnabled&rdquo; value= &ldquo;True&rdquo;/>

<add key= &ldquo;MaxHighPriorityMessageSize&rdquo; = &ldquo;900KB&rdquo;/>

I then stopped the SMTP services on the Windows 2008 box. The reason that I did this was to get the messages to queue up on the Exchange 2010 server. I then sent a large message that was over the maxhighpriortiymessagesize setting of 900KB to external domain that matches what I configured in the send connector. In my lab that message was 3 megs in size. I also did not set a priority on the message. I then sent a small high priority message to the same external domain. I then checked the queues to make sure that the messages were queued up on the Exchange 2010 server.

I then started the IIS SMTP service on the Windows 2008 box. I then checked the queue folder and you should see the smaller message with the high priority come in first and then the larger message. Please note that if you look at the date and time stamps on both the messages and the file they may show the same time. The best way to confirm this is to run either Network Monitor or Wireshark and take a trace of the messages being submitted either from the Exchange server or IIS box. Then look at the SMTP traffic in the Network Monitor or WireShark trace. The smaller message with the higher priority set on the message will be delivered first followed by the larger message that has normal priority.

The DowngradeHighPriorityMessagesEnabled parameter in the Set-Mailbox does work in downgrading message priority of the messages that are sent to other Exchange users and external SMTP recipients so that Exchange does not use priority of the message in queuing and delivering of the message. It does not change the message priority when the recipient gets the message. So if a user marks a message with high importance that is not changed, just how Exchange uses that priority to route the message."

Hope this helps!

Kevin Ca

Kevin Ca
 
Status
Not open for further replies.
Similar threads

Similar threads

Top