EMC, EMS & Powershell issues. Cannot manage Exchange 2010 after install

Status
Not open for further replies.
S

Schumi7

Installed Exchange 2010 to Svr 2k8 SP2. 2K8 Svr is a member server in a 2003 Domain with a current running 2003 Exchange Server. All Exch Adpreps run, as well as 2008 Domain Adprep in expectation of moving to 2008 Domain. Ran all updates available for 2k8 before Exch install. Ran Powershell v2 update but it told me it was not needed. Installation proceded with no errors or warnings.

Launching Exch Mngmt Console, or Mngmt Shell gives erros and no connection.

For Exchange Management Console: The following Error occurred when searching for On-Premises Exchange Server: Connecting to remote server failed with the following error message: The WS-Management service does not support the request. It was running the command 'Discover-ExchangeServer -UseWIA $true -suppresserror $true'

For Exchange Mangement Shell: Connecting to remote server failed with the following error message : The WS-Management service does not support the request. + CategoryInfo : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportException
+ FullyQualifiedErrorId : PSSessionOpenFailed

For Powershell: Adding Snap-ins microsoft.exchange.management.powershell.e2010, and then the error: Import-Module : There were errors in loading the format data file:
Microsoft.Exchange.Management.PowerShell.Setup, C:\Program Files\Microsoft\Exchange Server\V14\bin\Exchange.format.ps1x
ml : File skipped because it was already present from " Microsoft.Exchange.Management.PowerShell.E2010" .
At line:24 char:34
+ Import-Module <<<< $_.Name -ErrorAction SilentlyContinue
+ CategoryInfo : InvalidOperation: :)) [Import-Module], RuntimeException
+ FullyQualifiedErrorId : FormatXmlUpateException,Microsoft.PowerShell.Commands.ImportModuleCommand

Bypassing the warning in the EMS allows me to run some cmdlets and I can see the HT, CAS and MB, and I can see both Exchange Servers listed. On the 2003 system I can see the new Exchange Group listing the 2008 Exchange Server and the routing group that it created. I am using THE Administrator account, all of the groups have been added to Active Directory and the membership appears correct. DNS is working and I can ping by FQDN or just server name. I was about to uninstall and reinstall, but I can't because mailboxes and routing groups have been established. Everything seems to be OK except that I cannot easily manage my new Exchange Server. I have been on this for 3 days now and have covered enough posts that I am now tripping over the same posts regardless of how I phrase the search terms. Nothing has worked so far.

Thank you in advance for your time. Regards, Schumi7
 
E

Ed Crowley [MVP]

Consider installing SP1 and its update rollup 1 for Exchange 2010.Ed Crowley MVP " There are seldom good technological solutions to behavioral problems."
 
G

Gen Lin

Hi,

Additional to Ed's comments, please first try to uninstall Powershell v2 update and see if the issue persists.



 
P

Praveen Chinayya K

On the CAS server,open Internet Information Services (IIS) Console Navigate to the Powershell Virtual directory which is available under Default Web Site and then on the righ hand side choose " SSL Settings" Doule Click " SSL Settings" and then uncheck " Require SSL" .Click apply on the right hand side top corner to save the settings in IIS.Restart IIS Close all Exchange Management Console and Exchange Management Shell and reopen it.
 
S

Schumi7

Thank you Ed.

I have not got to update rollup 1, but SP1 resolved the issue. The prerequisites ran to about 8 or 10 hotfixes before the service pack would even install. It is amazing how quickly you can develop tunnel vision. I thought I had run all the updates I could, but SP1 I had missed. A big headache over with. Thank you again.

Best regards,

Schumi7
 
Status
Not open for further replies.
Similar threads
Thread starter Title Forum Replies Date
T Problems opening the EMS and EMC - WinRM, Kerberos, Powershell Exchange Server Administration 4
L Lost use of 2010 EMC and EMS Exchange Server Administration 3
T EMC and EMS problems - Exchange 2010 Server 2008R2 Exchange Server Administration 2
M Unable able to initialize Exchange management (EMC and EMS don't work) - Access Denied Exchange Server Administration 16
J Exchange 2010 unable to access EMC or EMS Exchange Server Administration 15
B Two server DAG setup, second server EMC not opening Exchange Server Administration 3
B Can no longer get into my server configuration via the EMC Exchange Server Administration 1
P Error when trying to open EMC and Powershell Exchange Server Administration 4
M Exchange EMC Initialization Failed from workstation Exchange Server Administration 2
B EMC Permissions (Already tried solution in other post) Exchange Server Administration 1
P EMC is not initializing Exchange 2010.... Exchange Server Administration 12
J After Applying Exchange 2010 Sp1 Rollup the Build numbers in EMC remain unchanged 14.1.218.15 Exchange Server Administration 1
A Initialization failed at EMC Exchange Server Administration 2
C How to allow admins to enable ActiveSync and edit address book information in EMC Exchange Server Administration 3
R Outlook reports 23MB, OWA/EMC report 2.5GB Using Outlook 20
T Cannot add Members to Migrated Mail-enabled Security Group via EMC Exchange Server Administration 1
J Change Scope to include Account Forest in EMC Exchange Server Administration 1
A EMC ToolBox Options Missing Exchange Server Administration 3
S EMC won't open on remote station Exchange Server Administration 17
P EMC access denied... Exchange Server Administration 6
O Database copies are not all showing up in EMC after SP1 upgrade Exchange Server Administration 50
V 32 bit EMC for exchange 2010 Exchange Server Administration 5
D Binding a Static IP to the Default Website Breaks EMC Exchange Server Administration 7
D EMC reports 'Initialization Failed' Exchange Server Administration 3
I RBAC Authentication error - Remote EMC not able to access Exchange Organization Exchange Server Administration 13
P EMC Permissions Gone Part Deux Exchange Server Administration 40
S EMC Initialization failed on Get-ManagementRoleAssignmentForLogonUser Exchange Server Administration 7
Diane Poremsky Use PowerShell to log into Office 365 Exchange New Slipstick.com Articles 0
marcadamcarter Interrogate Outlook GAL with PowerShell Using Outlook 0
R Exchange - Locating a user that has log files but is not found using powershell Exchange Server Administration 1
Britonius Exchange Powershell to Remove Reviewer access from all Folders in a mailbox? Using Outlook 3
P Could the powershell Version be wrong? Exchange Server Administration 1
I Exchange 2010 Powershell Exchange Server Administration 1
B Create Exchange PowerShell Virtual Directpory Exchange Server Administration 3
à owa and powershell take times on exchange 2010 Exchange Server Administration 8
M PowerShell Get-Mailbox truncates fields in the results Exchange Server Administration 3
G Moving messages within mailbox via PowerShell Exchange Server Administration 1
N Failed Exchange 2010 SP1 Installation PowerShell "unauthorized operation" Exchange Server Administration 2
T You must Provide a value for this property on powershell cmdlet Exchange Server Administration 3
C ClamAgent free antivirus for exchange help with JS in Powershell 2.0 Exchange Server Administration 1
S Determine Managed Folder Policy for Mailbox in Powershell Exchange 2010 SP1 Exchange Server Administration 4
W PowerShell Help in Exchange 2010 Exchange Server Administration 14
S Applying Managed Folder Policy using Powershell Exchange Server Administration 2
F Powershell help required Exchange Server Administration 4
T Unable to install SP1: "virtual directory 'PowerShell' already exists" Exchange Server Administration 8

Similar threads

Top