'The Server does not support a SSL conncetion' Mail client with Exchange 2010

Status
Not open for further replies.
G

Gagwithgaffer

Gents, I have a UC Cert installed into exchange 2010, I have also double checked that SMTP as well as IMAP services are assigned to the certificate. For some reason if I enable the tick box 'This server requires a secure connection (SSL)' for my outgoing mail within the mail client, then the mail client fails to connect to my Exchange Server.

Could someone possibly tell me why this is? I have now tried this with two seperate UC Certs.

The SSL connection ticked for my incoming mail on IMAP port 993 works ok.
 
S

Sembee [MVP]

Ensure that the host name that you are using for the server matches the common name on the SSL certificate, not one of the additional names. Although if possible, use Outlook and Outlook Anywhere. All other clients should only be used if Outlook is not available (Linux for example).

Simon.

Simon Butler, Exchange MVP
Blog | Exchange Resources
 
G

Gagwithgaffer

I tried to create a new receive connector in Exchange GUI for port 465 (SMTP SSL) on all available IPv4. Then set the authentication allowed for all methods and permisssion groups. This time if I try and send mail, i get the task message window come up saying it is connecting, no error is reported but it still never connetcs and the progress bar never moves. I can confirm the outgoing server address field (in mail client settings) is the same as the primary domain name on my UC Cert.

Can you add other ISP mail accounts to outlook anywhere?

Thanks
 
S

Sembee [MVP]

You shouldn't need to create a new Receive Connector, unless you have removed the ones creates by setup. Exchange 2010 creates two connectors - a default one (for external email) and a client one (designed for sending email via SMTP over SSL, aka TLS).

You can add other ISP accounts with Outlook Anywhere, you would have to create the Exchange account first. However do be aware that will store the other ISP email in with your Exchange email by default. In networks that I manage, adding personal accounts to Outlook is not allowed. If you want to use a personal account then you use a web mail service, Outlook Express or Windows Live Mail.

Simon.

Simon Butler, Exchange MVP
Blog | Exchange Resources
 
G

Gagwithgaffer

Hi

I can confirm i have not removed the 'default' or 'client' receive connectors that came as default. I have tried further testing between the mail client and exchange.

Within mail client account settings, I have assigned my outgoing mail server as port 587 and selected 'my outgoing server requires authentication' using 'same settings as my incoming mail server' which is basically using 'log on using secure password authentication' That works fine but again i find that as soon as i tick the box 'this server requires a secure connection - SSL) then i get the error message saying my server does not accept a SSL connection. I have no idea why this won't work. I have obviously ensured that within the receive connector authentication settings that 'Transport Layer Security TLS' is enabled in addition to 'integrated windows authentication'

Ol
 
S

Sembee [MVP]

Why did you change the Client Receive Connector configuration? That isn't necessary. The client configuration is suitable for most deployments without any changes. Remember if you do make changes you should also restart Transport Service for them to take effect.

You cannot use Integrated Windows Authentication for TLS because that is a Windows only protocol, so that should not be enabled. SMTP is a basic (plain text) protocol, which SSL simply secures, in much the same way that HTTP and HTTPS works. Therefore the default settings would be fine.

The most common reason why it doesn't work is something getting in the way. Firewall or file based AV that is intercepting the SMTP traffic.

Simon.

Simon Butler, Exchange MVP
Blog | Exchange Resources
 
G

Gagwithgaffer

It's not my firewall, prooved that already, i tried reinstalling a default client receive connector with default settings but still no joy.

I come to the conclusion that exchange simply isn't registering the fact i have enabled TLS despite restarting the transport service several times. I dont know what you mean by a file based AV. I think if something was getting in the way would i not receive a different kind of error message rather than it just saying the server wont support a ssl connection? I have been testing this all on the same LAN or live mail client on the same machine as exchange, surely that isn't anything to do with it. Just to note I am using live mail for this as I want sync with my other accounts including hotmail. All my other machines are windows 7 so dont have a choice of client either way. Perhaps i need to try and reinstall the hub transport role in case something is corrupt, i'd rather not if can avoid it though.
 
S

Sembee [MVP]

File level AV is software that scans the file system, which you would have on all servers, workstations etc. Many of them will try to scan SMTP traffic.

You can verify if the server will accept secure connections via telnet.

telnet server 587

(where server is the name of your server).
Then type

ehlo

A list of commands will be returned. One of them should be starttls:

220 host.domain.local Microsoft ESMTP MAIL Service ready at Mon, 20 Dec 2010 22:49:19 +0000
ehlo
250-wrks.domain.local Hello [192.168.3.11]
250-SIZE 10485760
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-STARTTLS
250-AUTH GSSAPI NTLM
250-8BITMIME
250-BINARYMIME
250 CHUNKING

If you get anything else then something is inteferring.

Simon.

Simon Butler, Exchange MVP
Blog | Exchange Resources
 
G

Gagwithgaffer

Hi,

I opened up the client telnet app on an adj machine, typed in 'telnet server 587' (server is actually the name of my server machine) and then i hit enter.

Telnet line then comes up saying 'Invalid Command. type ?/help for help'
 
S

Sembee [MVP]

If you started telnet, then you just enter

open servername 587

If you are starting telnet from a command prompt (I never start telnet first) then I just enter telnet servername 587

Simon.

Simon Butler, Exchange MVP
Blog | Exchange Resources
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
A Task 'Hotmail - Sending' reported error (0x800CCC7D) : 'Your outgoing (SMTP) server does not support Using Outlook 8
P Does Microsoft Exchange Server EWS support WS-Security standard Exchange Server Administration 3
S Outlook for Mac 2011 Email Question.. Get this error message... The Server Does Not Support Secure C Using Outlook 2
P Outlook 2010 smtp.live.com gives error that server does not support encryption. Using Outlook 2
C does unchecking "remove from server after 14 days" cancel removal Using Outlook 2
J Outlook 2003 does not send or receive imap mail from server Using Outlook 0
C Outlook 2010 does not Clean Messages from Server Using Outlook 1
D does my mail server allow rely Exchange Server Administration 5
E Task 'pop.gmail.com - Sending' reported error (0x800CCC7D) : Your outgoing (SMTP) server does not su Using Outlook 5
R Exchange 2010 UM does not re-direct the call to Exchange 2007 UM server Exchange Server Administration 1
S Exchange 2010 CAS and MB role on same server, does OWA redirect to Exchange 2003 still work? Exchange Server Administration 5
A Does CAS-only server need Forefront security protection for Exchange 2010? Exchange Server Administration 4
N Re: Task 'Hotmail - Sending' reported error (0x800CCC7D) : 'Your outgoing (SMTP) server does not sup Using Outlook 3
A Does I need to move & upgrade Default Address Lists from EX2003 to EX2010 Server Exchange Server Administration 12
A Connect to server to views items Using Outlook 0
J Moved many emails to Outlook external folder, need to delete on Gmail server Using Outlook 14
icacream Enter your user name and password for the following server. Using Outlook 5
T How can Exchange be configured to sync/push one-way so that the server data can't be affected Exchange Server Administration 0
F outlook.com Exchane Server corrupts data Since September 2019 Using Outlook.com accounts in Outlook 6
llama_thumper Setting up forwarders on Exchange server Exchange Server Administration 0
W Encrypted connection to server refused Using Outlook 0
B Server errors Outlook 2007 Using Outlook 1
M Outlook 2016 Requesting data from server Using Outlook 0
R Copy Outlook Public Folders to a File Server Shared Folder Using Outlook 0
I IMAP - are emails dynamically fetched from server as required? Using Outlook 2
CWM030 Name Server's Exchange Server Administration 15
CWM030 Archiving ON the imap server Using Outlook 3
G How to have domain client use owa server instead of exchange server while connect to network Using Outlook 1
GaryW88 2016 Archiving IMAP keeping mail on Gmail Server Using Outlook 1
R Would creating a new profile cause Outlook to download all the old mails from the server? Using Outlook 1
P Microsoft Outlook is requesting data from the server Using Outlook 2
J Old unread emails on current date (MDaemon Server) Using Outlook 1
E Duplicate, nested account folders on ATT server Using Outlook 10
Cdub27 Your changes to this item couldn't be saved because Server Denied Operation (HTTP 403 Forbidden) Using Outlook 1
O Outlook 2016 0x800CCC0F 'The connection to the server was interrupted' Using Outlook.com accounts in Outlook 1
crazyboy Problems connecting to BCM on Server Using Outlook 2
M Problems Downloading Content from Server(s) Using Outlook 0
K IMAP Server Wants to alert you to the following: cannpt rename system folder Using Outlook 1
T Uploading Outlook 2016 Contacts to Exchange Server Drops "Company" field data in 30% of records Exchange Server Administration 4
Diane Poremsky Archiving Tools for Exchange Server New Slipstick.com Articles 4
Diane Poremsky Changing the Message Size in Exchange Server New Slipstick.com Articles 0
R Outlook 2007 - Shared Accounts and Resources without Exchange Server Using Outlook 0
J IMAP server Using Outlook 0
Diane Poremsky Exchange Server Updates March 2016 New Slipstick.com Articles 0
J Your IMAP server wants to alert you to the following: cannot remove system folder Using Outlook 3
oliv- "Online mode with Exchange server" vs "online" Exchange Server Administration 2
W Deleting Emails from the Server in Outlook 2016 Using Outlook 2
B Outlook not deleting messages from server Using Outlook 0
I Random Chinese characters in email copied from a pst file. Exchange Server 2016 Public Folder Exchange Server Administration 1
M Outlook 2010 Error: Your IMAP server closed the connection Using Outlook.com accounts in Outlook 1
Similar threads


















































Top