Autodiscover redirected

Status
Not open for further replies.
S

StuAndersen

Hi
We're having a issue getting autodiscover to work.
The problem is that requests sent to https://autodiscover.company.com/autodiscover/autodiscover.xml are redirected to the default url for OWA.
This is happening on all clients expect for locally on the server.
This is happening even if redirection is disabled on the whole IIS site. We're having troubles narrowing down where the source of the problem is.
The servers involved are on the same subnet, and there are no proxies involved.
Both OS (2008 SP2) and exchange (2007 SP3) is patched with latest SP's and rollups.
According to HTTP traces the client gets a 302 redirection when accessing the autodiscover URL.
Some tests and settings:

[PS] C:\>Test-OutlookWebServices | fl
Id : 1003
Type : Information
Message : About to test AutoDiscover with the e-mail address user@company.com.
Id : 1013
Type : Error
Message : When contacting https://autodiscover.company.com/Autodiscover/Autodiscover.xml received the error Too many automatic redirections were attempted.
Id : 1006
Type : Error
Message : The Autodiscover service could not be contacted.

Please note the 1013 error.
HTTP redirect in IIS configured as followed:

[PS] C:\Windows\System32\inetsrv>appcmd list config "default web site" -section:httpredirect
<system.webServer>
<httpRedirect enabled="true" destination="https://owa.company.com/owa" exactDestination="true" childOnly="true">
</httpRedirect>
</system.webServer>
[PS] C:\Windows\System32\inetsrv>appcmd list config "default web site/autodiscover" -section:httpredirect
<system.webServer>
<httpRedirect enabled="false" destination="" exactDestination="false" childOnly="false">
</httpRedirect>
</system.webServer>


[PS] C:\>Get-ClientAccessServer | fl AutoDiscoverServiceInternalUri
AutoDiscoverServiceInternalUri : https://autodiscover.company.com/autodiscover/autodiscover.xml

 
S

StuAndersen



Solved this minutes after posting.

We dug through all the IIS settings again and "Edit Feature Settings..." under "Error pages" (at site root level) was overlooked.

Path type was set to Redirect, changed it to File.

Leaving question up for later references.
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
Q Problems with Autodiscover Outlook 2016 Using Outlook 0
B AutoDiscover Forensics Exchange Server Administration 0
EXChange2013 Exchange 2013 AutoDiscover Tweaks? Exchange Server Administration 0
A Exchange 2003 Outlook 2010 64 Bit- AutoDiscover Connection Err - Certificate Exchange Server Administration 9
M Outlook 2007 AutoDiscover Using Outlook 0
A Exchange Autodiscover SSL issue Exchange Server Administration 7
M Initial Outlook Configuration with AutoDiscover populates wrong email address Using Outlook 5
N Outlook 2007 Clients Pointed to Wrong Domain Name for Autodiscover Using Outlook 2
N Exchange 2007 SP1 + Outlook 2007/2010 - Autodiscover for Outlook Anywhere and Out of Office not working Using Outlook 1
S Load balance Autodiscover with multiple CAS servers. Exchange Server Administration 2
S Load balance Autodiscover with multiple CAS servers. Exchange Server Administration 3
K testing autodiscover and exchange coexistence Exchange Server Administration 2
D CAS Autodiscover using -rpcclientaccessserver Exchange Server Administration 5
C The Autodiscover service couldn't be located. Exchange Server Administration 8
C Exchange server 2010 error "The Autodiscover service couldn't be located." Exchange Server Administration 1
J Autodiscover accounts on exchange 2003 with Outloook 2010 not working Using Outlook 4
Z Autodiscover Points to defunct Exchange 2010 Server Exchange Server Administration 5
M Autodiscover not configuring Outlook Anywhere Using Outlook 10
B Autodiscover error 0x800c8203 and encrypted connection is not available Exchange Server Administration 3
P Autodiscover URLs Exchange Server Administration 15
C Autodiscover Exchange Server Administration 6
I Exchange 2010 Profile AutoDiscover not working for some users Exchange Server Administration 1
S Exhcange 2010 autodiscover virtual directory Exchange Server Administration 4
D External Autodiscover Exchange Server Administration 3
S Exchange 2010 Autodiscover Problems, cannot connect Outlook clients using Autodiscover / Outlook Any Exchange Server Administration 4
G Exchange 2010/Outlook 2007 Can't get autodiscover to work for some users, but others work fine Exchange Server Administration 3
S Autodiscover issue Exchange 2007 Using Outlook 4
P Autodiscover will not work Exchange Server Administration 13
K Exchange 2010 Autodiscover Exchange Server Administration 1
P Autodiscover fails (Exchange 2010) Exchange Server Administration 7
P Autodiscover issues on Exchange 2010 Exchange Server Administration 7
S Exchange 2010 Outlook 2010 Autodiscover fails Exchange Server Administration 22
C Getting Autodiscover to work with other web servers ... Using Outlook 4
C Autodiscover Service Configuration Exchange Server Administration 5
B move mailbox- autodiscover Exchange Server Administration 25
T Autodiscover authentication Exchange Server Administration 2
A autodiscover issue with OL2010 but no issue with OL2007 Exchange Server Administration 10
K Autodiscover and SRV records Using Outlook 10
C Autodiscover Exchange Server Administration 5
C ex2010 outlook03 autodiscover working??? Using Outlook 5
S Autodiscover two AD sites two cas arrays Exchange Server Administration 4
O Autodiscover Exchange Server Administration 4
S Autodiscover FQDN certificate for secondary domain email? Exchange Server Administration 1
K Remove AlternativeMailbox - Autodiscover Exchange Server Administration 5
S Exchange 2010 autodiscover Exchange Server Administration 4
R Autodiscover virtual directory - recreation fails Exchange Server Administration 1
J Autodiscover not issuing CAS array to Outlook Clients Exchange Server Administration 2
A share one record for autodiscover between exch 2007 and exch 2010 Exchange Server Administration 4
O SSL certificate needed for autodiscover.domain.com Exchange Server Administration 12
C Windows 7/Outlook 2010 vs Windows XP/Outlook 2007 - Autodiscover authentication looping Using Outlook 1
Similar threads


















































Top