Exchange Server 2010 Installation error ""The domain is invalid. Property Name: Domain"

  • Thread starter MD MUDASSIR MUSTAFA
  • Start date
Status
Not open for further replies.
M

MD MUDASSIR MUSTAFA

I am installing exhcange server 2010 on windows serve r2008 R2, which is my domain controller also.

I have installed all the fixpacks recomended at the time of S/W prerequisite test of exchange server.

But when i install at the time of Hub transport role installation i am getting the error

=============The Log of error===============

Hub Transport Role

Failed

Error:

The following error was generated when " $error.Clear();

set-ExchangeServerRole -Identity $RoleFqdnOrName -IsHubTransportServer:$true -DomainController $RoleDomainController

" was run: " The domain is invalid. Property Name: Domain" .

The domain is invalid. Property Name: Domain

Click here for help... http://technet.microsoft.com/en-US/...=14.1.218.11&e=ms.exch.err.Ex88D115&l=0&cl=cp

Elapsed Time: 00:00:01

Client Access Role

Cancelled

Mailbox Role

Cancelled

Finalizing Setup

Cancelled

===============

I dont think installation of exchange server on a domain controller should be of any issue.

Please help me solve the problem.
 
M

MD MUDASSIR MUSTAFA

Thanks for the quick response.

I have alreday checked the link and also followed the steps of the above link , but still i am getting the same error.

Hi,

Do you install exchange 2010 by using setup.exe or setup.com?

To troubleshoot this problem, please first try the following steps:

Checked if the server has SPN setup correctly:

a. On the domain controller, open adsiedit,msc.

b. Expand to Domain,CD=Computer,

c. Right-click CN=<var>serverName</var>, and then click Properties.

d. In the Attributes list, click servicePrincipalName, and then click Edit.

e. Under Values, make sure that it contains the following Value: HOST/ServerNetBiosName

Then installing exchange 2010 again.

---------------------I cannot find out the cause of the problem . Please Help.
 
N

Neil Hobson

OK, sorry about that, but you didn't say what troubleshooting you had already done so we start with the obvious stuff first. :)

It does sound like there's an overall domain issue here. Have you tried the Exchange Pre Deployment Analyzer tool? That picked up a few domain issues on a recent project. Might be time to check out the overall domain/DC health here.

Neil Hobson | Principal Consultant | Silversands | www.silversands.co.uk | www.msexchange.org/neil_hobson | neilhobson.blogspot.com | twitter @NeilHobson
 
M

MD MUDASSIR MUSTAFA

Thanks for te reply .

I tried analyzer tool , I am sharing the output with you:::

======================================
Found 1 Active Directory domain(s) in the forest. : Found 1 Active Directory domain(s) in the forest.

Found 1 Active Directory server(s) running Windows Server 2008 R2. : Found 1 Active Directory server(s) running Windows Server 2008 R2.

Found 1 Active Directory site(s) containing Exchange servers: Default-First-Site-Name. : Found 1 Active Directory site(s) containing Exchange servers: Default-First-Site-Name.

Found 1 Active Directory site(s) in the forest. : Found 1 Active Directory site(s) in the forest.

Found 1 Active Directory tree(s) in the forest. : Found 1 Active Directory tree(s) in the forest.

Found 1 administrative group(s) in the organization. : Found 1 administrative group(s) in the organization.

Found 1 routing group(s) in the organization. : Found 1 routing group(s) in the organization.

Found 1 server(s) running Exchange Server 2010. : Found 1 server(s) running Exchange Server 2010.

Forest:

Domain: MYDOMAIN

Root domain: DC=mydomain,DC=com Domain: MYDOMAIN

Active Directory domain 'DC=mydomain,DC=com' is the root domain in the forest.

Organization: mydomain

Admin Group: Exchange Administrative Group (FYDIBOHF23SPDLT)

Found admininistrative group 'Exchange Administrative Group (FYDIBOHF23SPDLT)' in the directory. Admin Group: Exchange Administrative Group (FYDIBOHF23SPDLT)

Found admininistrative group 'Exchange Administrative Group (FYDIBOHF23SPDLT)' in the directory.

Routing Group: Exchange Routing Group (DWBGZMFD01QNBJR)

Found routing group 'Exchange Routing Group (DWBGZMFD01QNBJR)' in the directory. Routing Group: Exchange Routing Group (DWBGZMFD01QNBJR)

Found routing group 'Exchange Routing Group (DWBGZMFD01QNBJR)' in the directory.

Server: pag1

Active Directory site membership: Default-First-Site-Name Server: pag1 Exchange server pag1 belongs to Active Directory site 'Default-First-Site-Name'.

DNS domain membership: Server: pag1 Exchange server pag1 belongs to DNS domain ''.

Exchange server pag1 is running Windows Server 2008 R2. Server: pag1 Exchange server pag1 is running Windows Server 2008 R2.

Found Exchange server pag1 in the directory. Server: pag1 Found Exchange server pag1 in the directory.

Site: Default-First-Site-Name

Windows Server 2008 R2 domain controller Site: Default-First-Site-Name

Domain controller 'PAG1' is running Windows Server 2008 R2.

==========================================

The above is the output of the echange pre install analyzer.

please help me out.
 
Status
Not open for further replies.
Similar threads
Thread starter Title Forum Replies Date
T Outlook INBOX emails gone back 2-3 weeks after Exchange Server 2010 Restart Using Outlook 0
S Outlook 2010/Exchange 2010 Multi Mailboxes (Server unavailable) Using Outlook 6
I Shared Contacts in Outlook 2010 and Exchange Server 2010 Using Outlook 4
A emails disappearing from inbox outlook 2010 exchange server 2010 major trouble Exchange Server Administration 6
R Change Outlook 2010 Exchange server address via registry or script Using Outlook 5
P exchange server 2010 installation Exchange Server Administration 2
A Exchange 2010 SP1 Edge Server ( Content Filtering ) Exchange Server Administration 0
B Installation of Exchange 2010 on a SBS2008SP1 Server. Exchange Server Administration 2
M Outlook 2010 stopped connecting with Exchange server Using Outlook 1
J Setup mail for Exchange 2010 through Active Directory on Server 2008 R2 Standard Exchange Server Administration 3
D Exchange Server 2010 SP1 Hosted Mode, service@ mailbox creation Exchange Server Administration 1
S Exchange server 2010 installation error Exchange Server Administration 3
J Exchange server 2010, Enterprise CAL vs. Standard CAL Exchange Server Administration 1
T "De-license" Exchange 2010 server Exchange Server Administration 3
V Uninstall ONLY Exchange 2010 but leave Exchange 2003 server in place - Public Folders Question Exchange Server Administration 5
G 'The Server does not support a SSL conncetion' Mail client with Exchange 2010 Exchange Server Administration 9
M Outlook 2010-Sync with Exchange server 2007 Using Outlook 2
R Dynamic DNS update requirement for Exchange 2010 (SP1 RU1) on server 2008 r2 Exchange Server Administration 8
M Integrated OCS with Exchange 2010 OWA didn't work over ISA server Exchange Server Administration 4
P Number of database on a server in DAG Exchange 2010 sp1 Exchange Server Administration 3
B Re: Upgrade windows server 2008 std R2 to Windows server 2008 Ent R2 with exchange 2010 Exchange Server Administration 1
A outlook 2010, windows 7, exchange server: "The action cannot be completed. The connection to Micro Using Outlook 1
H Exchange server 2010 cannot update default offline address book Exchange Server Administration 2
M Outlook 2010 Connectivity with exchange server 2007 Using Outlook 1
J Outlook 2010 Microsoft exchange server to pop account type switch? Using Outlook 2
N Outlook prompts for Password to connect to old Exchange server 2010 Using Outlook 1
V Exchange 2010 - problem sending mail from one server Exchange Server Administration 5
S Microsoft Exchange Server 2010 Not Receiving External Emails For New Users Created Exchange Server Administration 2
A I have purchased a replacement computer and installed Outlook 2010. My server is a 2003 small business exchange server. How can I access the calenda Using Outlook 1
M Exchange 2010 Outlook Web App via Exchange 2003 Front End Server Exchange Server Administration 1
J Exchange server 2003 to 2010 Exchange Server Administration 1
S Outlook 14 lose contact with our exchange server 2010 after Windows 7 have been in power save mode. Using Outlook 2
C Exchange server 2010 error "The Autodiscover service couldn't be located." Exchange Server Administration 1
F Outlook 2007 custom views do not show emails with Exchange 2010 Server Exchange Server Administration 2
F Outlook 2007 custom views do not show emails with Exchange 2010 Server Using Outlook 2
M Exchange 2010 DAG Witness Server Help Exchange Server Administration 2
C An attachment is not visible when an Exchange Server 2010 user opens a signed mail message by using Exchange Server Administration 1
P Error 4999 after Exchange 2010 SP1 - No BES server Exchange Server Administration 12
S Do you need a CAS Server in Order to Use OWA in Exchange 2010 (E14)? Exchange Server Administration 9
S Exchange Server 2010 installation help Exchange Server Administration 2
J Exchange 2010 server sending all email to 1 user as plain text Exchange Server Administration 2
C Outlook 2010 configuration issue "exchange server is unavailable. Using Outlook 4
C Outlook 2010 and Exchange Server not playing nice together. Using Outlook 3
S Any system impact if change exchange 2010 CAS/HUB and Mailbox server IP address Exchange Server Administration 1
S steps to consider while adding additional exchange 2010 server Exchange Server Administration 4
Z Autodiscover Points to defunct Exchange 2010 Server Exchange Server Administration 5
S Unable to restore Mailbox from Exchange server 2010 Mailbox Database. Exchange Server Administration 10
B Can't setup Outlook for Mac 2011 with Exchange Server 2010 - Connection Issue Exchange Server Administration 8
J Problems accessing console of Exchange 2010 on Windows Server 2008 R2 Please help me Exchange Server Administration 4
A SCOM 2007 R2 not able to see Exchange 2010 mailbox server Exchange Server Administration 4

Similar threads

Top