OWA can't delete mail

Status
Not open for further replies.

replay

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
Hello,

I have Exchange 2010 running with SP2 installed. Since i upgraded to SP1 then to SP2 i can't delete emails in the OWA, i have OWA running on port 8000. when its running on port 8000 i can't delete emails. when i set it back to default (443) then i can delete email. I can delete email in the OWA Lite version. I want it on port 8000 because my ISP is blocking port 80 and 443. Oh and ActiveSync is working well on port 8000 ist just in the OWA i can't delete email.

Thanks in advance.
 

Cathy Rhone

Senior Member
Outlook version
Outlook 2013 32 bit
Email Account
Exchange Server 2010
An isp is blocking 80 and 443? How do you surf the web with those ports blocked? Or do you mean you are running a server and the isp is blocking non-business subscribers from running server?

Do you get any error messages when you try to delete messages?
 

replay

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
An isp is blocking 80 and 443? How do you surf the web with those ports blocked? Or do you mean you are running a server and the isp is blocking non-business subscribers from running server?

Do you get any error messages when you try to delete messages?

Yes i mean my ISP is blocking non-business subscribers from running a server. When i delete an email i get the error message:

Code:
the selected action can not be performed because there is a configuration problem on the server. contact your helpdesk

eventlog says this:

Code:
Outlook Web App couldn't connect Exchange Web Services due to a configuration error. Response code = "null, webException.Status = ConnectFailure".

I tried the following:

1. reset the virtual directory databases; autodiscover, ecp, ews, activesync, oab, owa

2. check the internal and external url for OWA under client acces. Its set to https://domainname.com:8000/owa the same for ECP but with :8000/ecp

3. i checked the binding for default web site in IIS7 https is binded on port 8000 on the ip adres of the server. Also tried to set it to "no allocation" then the * appears on the ip address

4. when i changes something i did iisreset.

5. rebooted the server several times.

6. tried to set in iis7 under default website owa and ecp authentication anonymous and windows authentication on but with no success.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
it's a known issue. It's recommended that you use a firewall to port forward and leave the ports set on the default in Exchange as some ports are hard coded. It may also work to create a NEW web site using the different ports then configure it for exchange using powerskhell commands -

New-OwaVirtualDirectory -WebSiteName "Microsoft Exchange CAS"

New-EcpVirtualDirectory -WebSiteName "Microsoft Exchange CAS"

New-ActiveSyncVirtualDirectory -WebSiteName "Microsoft Exchange CAS"
 

replay

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
it's a known issue. It's recommended that you use a firewall to port forward and leave the ports set on the default in Exchange as some ports are hard coded. It may also work to create a NEW web site using the different ports then configure it for exchange using powerskhell commands -

New-OwaVirtualDirectory -WebSiteName "Microsoft Exchange CAS"

New-EcpVirtualDirectory -WebSiteName "Microsoft Exchange CAS"

New-ActiveSyncVirtualDirectory -WebSiteName "Microsoft Exchange CAS"

Ok thanks. I gonna try that, I am a newbie to exchange so I think i start over and only use 2010 and don't upgrade to SP1.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
Before you start over, i would try creating a new website in iis and running those commands on it. If it gets screwed up, no great loss since you are going to start over anyway. If it works, it saves you the effort of reinstalling.
 

replay

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
Before you start over, i would try creating a new website in iis and running those commands on it. If it gets screwed up, no great loss since you are going to start over anyway. If it works, it saves you the effort of reinstalling.

Do I create a new website under "default web site" or outside the "default web site" and what to do with the current OWA, ECP and ActiveSync under default website? And how to tell to exchange to use the new created websites?
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
Create a new website at the same level as the default web site. I think you can set the old website to stopped for now, but may need to delete it. Set the ports then run the cmdlets.
 

ckuriger

Member
Outlook version
Outlook 2010 32 bit
Email Account
Exchange Server
For what its worth, experiencing the same problem after having changed from the default port 443. By doing this, it not only creates a problem with OWA not being able to delete, but it also creates a problem with Out Of Office Assistant configuration access from Outlook with a server unavailable error message. Temporarily setting IIS back to 443 until a solution can be found, possible using the solution below of port forwarding at the firewall...
 
Status
Not open for further replies.
Similar threads
Thread starter Title Forum Replies Date
A Cannot delete mail in OWA only after upgrading Exchange Server 2010 to SP1 Exchange Server Administration 30
S OWA 2010 Cannot Delete Messages Exchange Server Administration 9
T After updating Exchange 2010 from RTM to SP1, OWA clients cannot move or delete emails Using Outlook 4
K Some user cannot delete email in OWA Exchange 2010 SP1 Exchange Server Administration 5
P OWA Settings->Calendar->Events from Email; Setting changes do not hold Using Outlook 1
G How to have domain client use owa server instead of exchange server while connect to network Using Outlook 1
J OWA vs. Outlook 2016 Bandwidth Exchange Server Administration 1
O Synchronize safe persons Outlook 2016 -> Outlook Web Access (OWA) Using Outlook 30
C OWA External Access - No URL / URL Invalid Exchange Server Administration 2
Diane Poremsky New Office365 Feature: URL Preview in OWA New Slipstick.com Articles 0
J IPAD Outlook OWA App - Help using Exchange 2007 Using Outlook 4
S Cannot disable OWA light Exchange Server Administration 5
J Stuck using OWA Exchange Server Administration 0
T Outlook Calendar Sync MY GOAL: see work calendar on home desktop w/o OWA Using Outlook 2
T Sync OWA? Exchange Server Administration 0
O Multiple simulteniously opened OWA 2010 accounts in one browser work fine ! Using Outlook 3
S Newly added user doesn't show up in GAL but available in OWA, Using Outlook 0
B Customize OWA page to open in a new window when logging in Exchange Server Administration 1
B OWA Calendar Views not available Exchange Server Administration 2
O outlook 2010, owa, exchange Exchange Server Administration 2
B Searching OWA Additional Mailbox - in which Secondary folder is the email? Using Outlook 1
D OWA and Windows 8 Exchange Server Administration 1
Z OWA Mailbox unavailable Exchange Server Administration 2
G Outlook 2013: Getting meeting invites in OWA format Using Outlook 9
R Lost Outlook 2007 message found in OWA Using Outlook 4
D OWA Send invitation AS (not from) Exchange Server Administration 1
E OWA phones home too much? Exchange Server Administration 1
S Cannot open any attachment from OWA Exchange Server Administration 2
T Syncing OWA 2010 to Outlook 2007 Exchange Server Administration 15
J Outlook and owa access Using Outlook 1
S Track emails in OWA Exchange Server Administration 1
T OWA and post dating Exchange Server Administration 1
S Unable to Sync Phones but OWA connects Exchange Server Administration 1
B [SOLVED] Forced to type Domain/username for OWA 2003 with IE 7 or 8 Exchange Server Administration 3
M Attachments cannot be opened in Outlook, OWA works fine Using Outlook 2
T OWA Folders Using Outlook 0
A Managing GAL via OWA Exchange Server Administration 5
J Mail read in OWA won't appear in Outlook Exchange Server Administration 1
1 mobile OS or apps for sync of all OWA/exchange PIM functions Exchange Server Administration 3
A OWA Certificate Expired Issue Using Outlook 1
C OWA 2010 Nicknames Multiply Using Outlook 3
S Signature size limit for OWA / Exchange 2010 Exchange Server Administration 10
T Military OWA on Outlook Using Outlook 1
T owa Exchange Server Administration 2
M Exchange 2010 OWA Redirect with Authentication Across AD Site Exchange Server Administration 1
J OWA 2010 Sp1 custom themes Exchange Server Administration 2
L User not shown in Adressbook but is shown in Adressbook using OWA Exchange Server Administration 6
K OWA breaks after moving mailbox to exch 2010 Exchange Server Administration 6
J Missing options in OWA Premium 2007 for some users Using Outlook 0
B OWA 2010 FBA Exchange Server Administration 2

Similar threads

Top